Top 6 Causes of a Car That Won’t Accelerate

Last Updated on March 9, 2021

The symptoms of a car not accelerating like it used to can occur on many high mileage vehicles. A driver might not notice these signs in normal day to day driving but they become abundantly clear when driving up a steep hill or when quickly trying to accelerate into fast moving traffic.

Looking for a good online repair manual?
Click Here
for the 5 best options.

It is in those situations that drivers will come to notice the obvious slow acceleration and the fact that the engine of their vehicle is struggling to keep up.

Read also: Symptoms of a Faulty Speed Sensor in Your Vehicle

Common Causes of Car That Won’t Properly Accelerate

This is a common problem in high mileage vehicles but there are no serious or immediate concerns regarding major engine problems. Some of the causes are actually minor and should be checked first in order to locate the issue and possibly fix it as well. Here are some of the most common causes:

#1 – Mass Air Flow Sensor Clogged or Malfunctioned

MAF sensor

The mass air flow sensor (or meter) is located and attached to the inlet air cleaner. Since the function of the air flow sensor is to measure air mass that is flowing into air intake, a clogged or bad mass air flow sensor could send the wrong data to the engine ECU for calculating the air fuel mixture.

A very symptom of an air flow meter malfunction is car that won’t accelerate correctly.

#2 – Oxygen Sensor Malfunction

oxygen sensor

An oxygen sensor is device whose function is to monitor the exhaust emissions of the vehicle so that it can analyze the air-fuel ratio going through the engine of that vehicle.

To make a long story short, a car needs a proper amount of fuel in order for the fuel to burn properly in the combustion cylinders so that it may run smoothly and may accelerate as required.

This sensor sends the information about the amount of fuel being used to the computer unit of the engine and if this sensor get damaged, then the engine of that vehicle will have no idea what ratio of air-fuel mixture to use which may result in a fuel rich mixture.

This can cause the slow acceleration of the vehicle even with the accelerator pedal completely pressed making it unreliable when it’s needed.

#3 – Malfunction of TPS

TPS sensor

The basic principle of the throttle position sensor (TPS) is to detect the throttle valve opening angle which is controlled by accelerator pedal. Then the TPS will send this data to the ECU.

If the TPS malfunctions, the engine speed cannot be controlled by the accelerator pedal and engine speed will increase or decrease without any press or depress the pedal.

#4 – Dirty or Clogged Fuel Filter

fuel filter

A dirty or clogged fuel filter is another reason for a car not accelerating like it’s supposed to when required to do so.

With a dirty fuel filter, the engine won’t be getting enough fuel which means that the vehicle won’t be giving the acceleration performance that it should. Replace the fuel filter as soon as possible.

#5 – Clogged or Dirty Air Filters

dirty air filter

Just like a fuel filter provides the engine with the clean fuel, an air filter provides the engine of a vehicle with clean air to be used in the air-fuel mixture which will be sent to the combustion chambers to burn.

If an air filter is clogged, then the engine won’t get the right air-fuel mixture resulting in slow acceleration. Replace the air filter as soon as possible.

#6 – Timing Belt

bad timing belt

This component is as it sounds. The timing belt is something like a VIP in the list key of components of an engine. If this belt is off even by 1 tooth, it may cause some pretty notable acceleration problems.

However the list of causes of poor acceleration does not end here. Other culprits behind slow acceleration may include a slipping clutch, the transmission system itself, or an unexpected or unrelated problem which may surprise even veteran mechanics.

If you’re not comfortable troubleshooting a car that won’t accelerate, I recommend taking the vehicle to a reliable mechanic and let him give it a full checkup. This will allow him to properly diagnose the issue and recommend a suggested fix.

 

351 thoughts on “Top 6 Causes of a Car That Won’t Accelerate”

  1. I have a Toyota Avalon 2005,which I drove out with smoothly in the morning and come back to park it.three hours later i wanted to take it out and the car started jerking and unable to accelerate properly.please what can be the cause.

    Reply
    • I have a 2007 Nissan bluebird sylphy and when I start the car the car can move but when i give it gas it’s not giving me a full rev it’s go vom vom and it’s not passing 2 on the clock I give it to the election to check and they can’t find the problem what should I do?

      Reply
  2. I have a 2011 Chevy Silverado 1500 5.3. I’ve been having issues with it the last few days. I’ve had the check engine light on for a while now, one code saying the fuel is too rich and another saying it’s too lean, and I noticed there’s a lost of performance with the truck. But I filled up the truck a couple of days ago and put some fuel cleaner additive and the next day I was in a drive thru and it’s making a really weird noise like a rattling noise or something and then it just wouldn’t go. It’ll start and run all day long and idle but when I’m pressing the gas it just won’t go. I thought for a minute it was the MAF sensor because I noticed it was unplugged but I got a new one and plugged it up and unplugged the battery to reset the pcu and it’s still doing the same thing. It will run fine for about 5 minutes and then back to it. I’m thinking it might be the fuel pump but I’m not sure. Please help

    Reply
    • You’re probably going to have to do some diagnostic work to uncover the cause of the issue. It does sound like it may be a fuel system issue, so I’d start by changing the fuel filter if it’s been a while since that was done. It should be done regularly anyway. Next, you could do a couple different fuel system tests to see if everything is working properly, such as a fuel pressure test.

      Reply
    • I would check all sensors first Cam/crankshaft,TPS,Oxygen,
      MAF. If its cam/crankshaft sensor(s),spark plugs,air filter all should be checked. Ive been going thru same type of issues w/my Nissan Maxima. Have codes read. Good Luck

      Reply
  3. I have renault Clio 2 2005 model, MY car have a problem of acceleration after a few kilometers of Traffic JAM. It will not accelerate even if I press the gas pedal. I have to turn of th engin cool it for few minutes and start driving again? any idea?

    Reply
  4. Hi, i have a 2006 D4D 4×4 TD Hilux. I have a power/acceleration problem that occurs sporadically. It usually starts happening around 2000 rpm than all of a sudden finds power again and off she goes. Changed fuel, air filters etc and have had the air flow sensor cleaned. Any ideas on what this may be?
    Thanks!

    Reply
    • Do you have any check engine lights? You will probably have to look at some scan data to point you in the right direction. A good shop should be able to do this if you don’t have a capable scan tool.

      Reply
  5. Hi. I have a Mitsubishi Lancer 2006, and when on incline, it looses power and won’t accelerate and move. However, as long as it’s in motion this is never a problem, it has no power issue either; only when it’s beginning to move on incline. It also has vibrations when it’s on gear but idling, not sure if it’s related. Any idea what could be wrong?

    Reply
    • Hi Samuel. Unfortunately there is not enough information to really take a stab at the problem, as there could be many things that could cause a loss of power on a hill. You’re probably going to want to take the car into a local mechanic’s shop so they can diagnose the problem.

      Reply
    • my car vibration on 3rd and 4th gear but I can live with it since driving on flat surface we can drive slow, no problem. It just annoying that the people behind me be thinking that I drive slow on purpose after a stop is annoying. I try not to press the pedal too hard when changing gears. Going up the hill, you got no power right? You are running on less cylinder. Your 4 cylinder car is now a 3 cylinder car. I think you change your spark plug and get a new set of coil and see if that would solve the problem. Mine has no check engine light on and my odb reader shows nothing.

      However, my case is different because my 011 camry has 365k miles on it. I abused my car and only change oil and oil filter only. Did tune up just a few times and everything stock like o2 sensor, fuel filter, shift solenoid or anything else for that matter. It has a slightly motor oil leak but adding a quart from time to time doesn’t stop the car from running. Same thing with power steering fluid leak, if not a big leak, you can top oil and you be good. So yeah, I feel your pain.

      Reply
  6. I have a 03 Toyota corolla, it suddenly refuse to throttle properly anytime I pass through small portion of water. Will have to continue throttling for minutes before it picks up again…. Please what could be the cause

    Reply
  7. I have a 2008 Toyota camry, if I start the car in the morning and switch to drive it doesn’t move until I push the throttle high before it starts moving and after some minutes it picks normally and I can use it throughout the day without any issues but when the temperature of the car calms down after 3-4 Hours it starts misbehaving again. But my reverse moves smoothly. Thank you

    Reply
    • Perhaps your parking brake is getting stuck. If your rear brakes are dragging, it will become easier to move the car after the brakes get so hot that they start to fade. It’s also possible that one or more rear calipers could be stuck even if you’re not using the parking brake much.

      You may be able to replicate the issue to confirm it’s the parking brake like this: while parked in a safe area away from traffic, engage the parking brake like you normally would when you park. Next, release the parking brake, shift into drive, and see if it’s harder to get the car moving. If it is, you likely have an issue with the rear brakes.

      If your parking brake is stuck, your rear rotors will probably have bluish hot spots on them. This happens when brake rotors overheat. If you see hot spots, you should strongly consider changing the brake pads, brake rotors, and brake fluid. If you’re not sure what these hot spots look like, google “overheated brake rotors” for a few examples.

      Reply
  8. But I really do not use parking brake. First thing in the morning when I start my car and engage in drive, it suppose to roll on its own without throttling, but I have to rave the engine from 1,3 before it will move. I will have to continuously rave the engine for it to move for some minutes before it picks. It functions very well on therne road without troubles but after using it or when is been parked for hours and by then the temperature of the car has dropped, it falls back to that same problem. Thank you.

    Reply
    • Hmm. I am not certain on this, but that actually sounds more like a transmission issue than a brake issue like I originally thought. I don’t really have a great recommendation there. If it were me, I would bring it by a transmission shop and see what they say. They may charge you a small amount to do some diagnostics on the vehicle, but it is well worth the cost in my opinion.

      Make sure they are able to replicate the issue you are having before you drop the car off.

      Reply
    • Ernest, I have exactly the same problem Toyota Corolla 2004, 135K miles, except that in the morning when it’s cold it will start ok, but will need to be revved up to 3K RPM if I stop at a light. Once engine warmed up, drives with no issues at all, no Engine lights. I don’t think it’s transmission, some kind of sensor. Anyone has any clues as to what it may be?

      Reply
  9. I have a 2013 Hyundai Sonata hybrid. When I push on the break my Car jerks and then it feels like it still wants to go for a second and also sometimes when I push on the gas it will only go to 20 mph and then the RPMs go up real high and then I’ll eventually be able to go

    Reply
    • It sounds like you may have a throttle control issue somewhere, or maybe a transmission issue… I’m not really sure given the description of the problem. It will probably need to be diagnosed at a shop so you can figure out exactly what is wrong. I wouldn’t drive any more than you have to until it’s fixed. If it’s a throttle control issue, that is very dangerous and could result in unintended acceleration if the issue is not addressed.

      Reply
  10. I have primers 2015 desiel car the problem is sometimes it will not throttling will not work and sometime when I start it it will just throttle down

    Reply
    • Is the problem intermittent, or are you able to replicate the issue consistently?

      Knowing how to replicate the issue is a key detail mechanics need to know. This will shorten the diagnostic process at the shop and could save you a lot of money.

      Reply
  11. I have 2013 Nissan Almera. I have been having this poor acceleration problem which I was suspecting it’s from the fuel pump area. Sometimes, when I unplug the fuel pump switch and plug it back firmly, it picks and raises well but after some times it wasn’t working like that so I bought another switch but the case remain the same. What could be the problem? At times, it picks on its own and return to the poor mode after awhile.

    Reply
    • I would start by testing the fuel system. Try to figure out if it is a mechanical problem that is limiting fuel, or an electrical one. This will help you narrow things down.

      Reply
      • Hello, I was driving and my petal went limp I let off and it went back to normal but I couldn’t accelerate.my car was still running and I pulled over killed it and tried to recrank it. It turned over but never cranked. What could be my issue ?

        Reply
        • What is the year, make, and model? Do you have throttle cables or a drive by wire throttle?

          If you have throttle cables, perhaps those broke or were detached. You should be able to see this in the engine bay. The throttle cables attach near the throttle body. Follow the air intake until it reaches your engine and you will find the throttle body.

  12. I have a 2001 Acura TL and when I bought it I really needed a vehicle cause my trailblazer had issues so I sent it back to the dealership. The Acura already had 213,000 miles on it and I paid 3500 with TTL included. A few days after I had it the engine light came on and the TCS light came on with it. The TCS light went off but the engine light remained on. It started slowing down as I drive it and I had to pull over several times and cut the car off then back on then it was fine. A few days later same thing. Finally after a few weeks of this it happened again except the gas pedal wouldn’t move when the gear was in (D) Drive. I could hear the it accelerating except the car wouldn’t move in Drive or Reverse. After 10 minutes it started to move but it was stalled. Meaning it took it’s time going into gear. So I didn’t want to risk driving it back home so I got it towed. Any suggestions on what could be the problem?

    Also, after it sat for 3 or 4 days I cranked it up and white smoke was coming from the tail pipe and the engine seemed to get hot faster than usual. It wasn’t running hot but the water started to evaporate in the radiator.

    Reply
    • It sounds like you may have an issue with the transmission that’s causing slipping. Perhaps it’s not actually getting into gear when you’ve selected Drive or Reverse. Check the transmission fluid, make sure it looks good and the level is correct. There could be an issue with a shift solenoid in the valve body that’s locking you in a specific forward gear or not registering when your shifter has moved. You’ll need to do a bit more diagnostics to find out.

      What were the check engine light codes?

      Reply
      • I have a 2004 nissan murano with this problem.! When i have to stop at a red light…i have to tap and press on the gas pedal about 6 times before the rpm’s get high enough for me to actually start moving.! Then when it does move it eggs 3 real high and takes the hell off.! Any ideas.?

        Reply
        • I don’t know. You could check the wheels to see if one is warmer than the other after this happens. Be careful though, the wheels may be very hot if there is a stuck caliper, bad wheel bearing, etc.

  13. My car feels like the brakes are engaging while I’m driving, and I need to give it more gas to maintain the same speed, when I let it sit for a few minutes it goes back to normal. This has only started happening as the weather has been warmer and it seems to only happen after it has been on the road for about 20 minutes or so. This last time there was a burning smell like metal or something. Please help

    Reply
    • It sounds like you may have a bad brake hose or stuck caliper. It should be fairly inexpensive and straightforward to fix, but it needs to be addressed as soon as possible.

      Reply
  14. Hi. Love this site. Your help is soooo appreciated. I drive a benz c320 ’05. Sometimes especially after a stop at a traffic light or so, it takes forever to respond no matter how much i press the pedal. It has like a 10 second delay between when i press and when it responds. But after that, car works perfectly fine and can outrun anything. This slow start is a pain. I have changed filter, pump, MAf and checked transmission. Please what could this issue be? No codes thrown.

    Reply
    • Thanks for the feedback! When your car is slow to start, does it rev and not move or does it just not respond at all? It sounds like there may be an issue with the accelerator pedal assembly or throttle position sensor that is not registering your inputs, but that is just a guess.

      Reply
  15. pls I have Nissan sunny 2010 ,I bought d car from someone ,after some days I started noticing dat d car is unable to start den I took it to a local mechanic and he said I should change d brain box,den I did and d car starts but after some days ,it started doing hard starting ,recently when I’m driving I try to accelerate but it ain’t accelerating .pls what might have be d cause pls

    Reply
  16. I have a 2006 Dodge Durango and i’m having issues with my acceleration/rpm. Check engine light came on and I press the pedal to the floor and it slowly picks up speed, not going over 3000 rpms. I tried turning the truck off and on again and it goes back to normal but check engine stays on. Not sure what’s going on, just started happening.

    Reply
  17. Hello. Thanks for the knowledge sharing. I have a Toyota Avalon 2008 with 295567 millage on it. While driving sometimes when i push on the accelerator the car won’t move then after a little while it pick and starts moving, it doesn’t jerk.
    I have changed the fuel pump, fuel filter, and clean the nozzles. the problem persist , what could be the issue?

    Reply
    • Check the spark plug condition and verify that spark plug gap is correct. Even if the spark plugs are not the root cause, their condition may give you a clue as to what’s going wrong. If they are really dark (or wet) you’re probably running rich, if they look white and/or burnt you may be running lean.

      Reply
  18. Check engine light is on and I can be driving along and it start decreasing in speed on its own. During this time rpm’s are around 3. What can be wrong?

    Reply
    • What codes were stored with that check engine light? That will help you narrow down the problem. I would get it scanned at your local auto parts store. Most places can do that for free.

      Reply
  19. I hav a Toyota rav4 2003. I hav changed its plugs, its coils, the oxygen sensors and even the fuel pump. Even so it doesnt move faster. It accelerate slowly and jerks off suddenly. What do i do

    Reply
  20. Can anyone help me?! Ok, 2007 Toyota Yaris, reaches 40m.p.h. at which point the r.p.m.’s go through the roof and the car stays at or under 40m.p.h. Now, I cleaned the air intake valve, I cleaned the MAF i cleaned all immediate areas and made sure all fluid levels are at required amounts. All of my hoses are changed out. The wiring to sensor modules look clean and are making clean contacts. I can’t figure it out without having a mechanic hook his OBD to it. No yime for that s#!t, no money left. Please help! I am a delivery driver and without my Yari I’m a homeless delivery driver. HELP!

    Reply
    • It sounds like the transmission may be slipping. Generally if the engine speed skyrockets while the ground speed stays the same (or you start to slow down), this is a telltale sign of a transmission slipping. Is it an automatic or manual transmission?

      Reply
  21. 2017 Chevy Cruze, all’s been good til the last few days I noticed that acceleration is slow up to like 10-15, then boom, car drives normally (at least until the next stop sign/red light). Any thoughts?

    Reply
    • I’m not sure. Have you noticed any hesitation or stumbling?

      You could pull the spark plugs to see if they tell you it’s been running rich or lean. I had a car that would hesitate off the line and the fix was new spark plugs.

      Reply
  22. 2004 ford ranger xlt. Runs fine for the most part but I noticed as I was driving it home I was coming up a hill before my house and it randomly just went down into an idle while my foot was on the gas. I pulled over and let my foot off for a few seconds and got back on it and the truck ran fine after that. I was hoping someone had an idea what areas I should check, I don’t want to bring it to a mechanic, don’t trust um in my area at all. Also just replaced my water pump, radiator, belt and it went fine then my fan clutch went and had midas replace that since I didnt have the tool to get it off and it still sounds like a big rig every time I start it let it sit then drive it up the road about 50-100 yards. Not sure if this could be related. Help please!

    Reply
  23. I drive a Ford Fiesta 1.0 Ecoboost 2013 model. I does not pull when i press the accelerator and it does not even flash the engine to show that it has the problem. Please assist.

    Reply
    • Not sure what the issue is. Check the basics: make sure the engine air filter isn’t too dirty, check for vacuum leaks, check the spark plugs and fuel injectors for proper function.

      Reply
  24. I have a Hyundai Sonata and one second it was fine. Then at a red light I couldn’t accelerate more than 10 mph and my rpms wouldn’t go past 2000. The check engine light was on as well but I only just noticed it.

    Reply
  25. My 02 protege is throwing a po300 code I’ve done change everything fuel pump, plugs and coils , maf sensor, cam and crank sensor,injectors seam to be working fine. When I try to accelerate with it in park .it just spits and sputter and sounds like a diesel engine but if i hit gas pedal just right and hike the ram engine sounds great ,idle it dont

    Reply
  26. I have Toyota Yaris 2016, due to sandy weather I tried to blow out all sand stuck on my machine compartments and also cleaned the air filter, but after a while of starting the engine then suddenly check engine came out on monitor and at the same time I cannot accelerate even the pedal already press down…

    Reply
    • Get that code scanned. Perhaps you knocked something loose like the MAF sensor connector, perhaps there’s a vacuum leak somewhere after the cleaning. The code from the check engine light will help you narrow it down.

      Reply
  27. Good day, my Toyota corolla 2004 with 200,000 plus mileage, check engine light is on, car will start and move fine without AC, whenever I put on the AC and step on the gas it slows to move, am suspecting my half and top engine. What to u think?

    Reply

Leave a Comment